Remote Potato needs Admin account to build libraries

Spotted something that's not working as you think it should? Post bug reports in here and read about the known issues.
Forum rules
No spamming, flaming, or abuse - play nicely!

Remote Potato needs Admin account to build libraries

Postby scottward01 » Sat Mar 17, 2012 6:47 pm

I've noticed that when I launch the Remote Potato GUI on Windows 7, it asks me if I want to associate Remote Potato with a user account so it can build media libraries for streaming purposes. The problem is, when I provide a username & password, it also updates the Remote Potato service with the same account info, so that the Remote Potato service tries to run under this same account. If that user is unprivileged, the service won't be able to start.

As someone who is always concerned about computer security, I never log into Windows with admin privileges unless I need to install something (this has become easier with UAC). If I let Remote Potato log in as Admin, then there are no libraries to build b/c it's not a user account. The other option is to promote my regular user account to Admin, but that's not a great idea since Media Center computers must be up and running (and connected to the Internet) 24x7. Therefore, you wouldn't want to remain logged in indefinitely as a Superuser just so that your media libraries were available for streaming via Remote Potato.

Thus for the time being, I cannot access pictures & music or other media belonging to my regular user account via the Remote Potato iPhone app. Ideally, you would decouple the service under which Remote Potato runs (normally this would be the "Local System Account"), and the account Remote Potato uses to build media libraries (normally this would be a regular unprivileged user account).
scottward01
Raw Potato
 
Posts: 1
Joined: Sat Mar 17, 2012 6:29 pm

Return to Support - Bugs

Who is online

Users browsing this forum: Majestic-12 [Bot] and 1 guest

cron