Page 1 of 1

[BUG] [MUSIC] Artist names displayed incorrectly

PostPosted: Mon Jun 20, 2011 11:34 pm
by Robklubs
I'm trying my best to figure out the exact scenarios here, but here goes . . .

If an artist or album name contains special characters (such as % or &) then some or all song names and artist name are semi-random. I say semi-random because it will include some measure of the root Artist, but it won't be quite right.

For example, for an album named 100% Fun, the first track has the artist's name in the title, "Matthew Sweet - Sick of Myself" but the other tracks just have title only. Refreshing the library doesn't fix, it changes the info. In this same example, the artist name on 100% Fun was changed to "Matthew Sweet & Susanna Hoffs", which has that special character. Tracks here have "Matthew Sweet" before any of the names. ("Matthew Sweet & Susanna Hoffs" is in the music DB as the artist on several other albums.)

Compilations or albums with multiple artists - the main/title Artist on these seems to be alphabetically chosen by first name. It's almost as if there is a lookup for artist when displaying the album, and that lookup includes any and all artists that include the root artist. Ukulele Songs by "Eddie Vedder" has "Dead Boys feat. Eddie Vedder" as the artist name. This would make sense if there was a lookup based on the root artist (D comes before E).

The individual track names do look correct, in the ARTIST - TITLE format, and are numbered correctly.

I should note that the tracks play beautifully (even in multi-task mode), the interface rotates, random and shuffle work, and adding songs to the current playlist is a snap.


-Rob

Server version 1.03
App Version 1.2 (1200) Beta 1

Re: [BUG] [MUSIC] Artist names displayed incorrectly

PostPosted: Tue Jun 21, 2011 12:54 pm
by Carlos
Thanks Rob - there certainly seems to be something odd going on with the association of Artists to tracks and albums.

Can you verify that, in the examples you gave, there is actually an 'Album Artist' field filled in, in your ID3 tags on the mp3 files themselves? If not, then it could be that the server is trying to guess at the album artist and doing so incorrectly. Either way it's a bug.

Carlos

Re: [BUG] [MUSIC] Artist names displayed incorrectly

PostPosted: Tue Jun 21, 2011 12:57 pm
by Carlos
Also, if anyone else can report back on this issue too, it would be useful - are people seeing the same behaviour? Is anybody able to narrow down the circumstances under which the names are displayed incorrectly?

C

Re: [BUG] [MUSIC] Artist names displayed incorrectly

PostPosted: Tue Jun 21, 2011 1:10 pm
by Robklubs
Yes, the Album Artist Tag is filled in for both examples I gave. Thanks.

Re: [BUG] [MUSIC] Artist names displayed incorrectly

PostPosted: Tue Jun 28, 2011 11:36 pm
by Carlos
I'm struggling to reproduce this one at the moment; I wonder if it's down to ID3 tagging at all.

Re: [BUG] [MUSIC] Artist names displayed incorrectly

PostPosted: Thu Mar 22, 2012 2:29 pm
by Robklubs
Removing album artists and trimming long album names seems to get this to work.