Windows Mobile 6 WVGA Client [Updated 8/12/2010]

Made a theme for Remote Potato, or an App using the API? Post the details here so other users can help test it, or just to show it off in all its glory!
Forum rules
No spamming, flaming or excessive self-promotion - play nicely!

Re: Windows Mobile 6 WVGA Client [Updated 8/11/2010]

Postby flatliner » Thu Aug 12, 2010 3:30 pm

Thanks got the app connected ... the new install did the trick ...

I got the same error message as mentioned above ... got it solved by ticking off the security box in the remotepotato server, but leaving name and password as it was.

Some more questions:

- It says it loads the guide for the channels but can't see it. Any ideas?
- Playing Recorded TV does not work as I have my streaming port set to 9081 (default), but media player looks for 90801. Is this hardcoded in the app?
- Are you going to add music & movie library as well? As media player play those streams as well.
flatliner
New Potato
 
Posts: 6
Joined: Wed Aug 04, 2010 6:47 pm

Re: Windows Mobile 6 WVGA Client [Updated 8/11/2010]

Postby spokanedj » Thu Aug 12, 2010 4:27 pm

flatliner wrote:- It says it loads the guide for the channels but can't see it. Any ideas?

If you click channels, do you have anything listed in the Chan drop down box? You should be able to select a channel and date, then click show to see all the shows for that day. I think I just realized that all times are GMT in that display.. Are yours off by your time zone?

flatliner wrote:- Playing Recorded TV does not work as I have my streaming port set to 9081 (default), but media player looks for 90801. Is this hardcoded in the app?

Check your server value and make sure its "http://myserver:9081" and not "http://myserver:9081/" or "http://myserver:9081 ". Currently I just take the server URL and replace the last character with a 1. Next release I'll pull the actual settings and use the defined streaming port.

flatliner wrote:- Are you going to add music & movie library as well? As media player play those streams as well.

I'm not sure. Music wouldn't be that useful as you would only be able to play one song at a time. Movies might be handy, but really not a high priority for me.
Smart Potato for Windows Phone 7: http://www.ntworld.com
spokanedj
Hot Potato
 
Posts: 80
Joined: Fri Apr 23, 2010 7:51 pm

Re: Windows Mobile 6 WVGA Client [Updated 8/11/2010]

Postby flatliner » Thu Aug 12, 2010 6:04 pm

- Yes I can see all channels. when I select one and press show the status line says i.e channel 3 loaded, but top and bottom box stay black/empty.

- Taking away the "/" did the trick ... although the streaming image window is quite small ... using the full size button in media player still gives a small streaming image window. can I change that setting somewhere?

- well if you have time left movies would be great ... as said I don't mind too help out with the design ... making it look as cool as the iphone app
flatliner
New Potato
 
Posts: 6
Joined: Wed Aug 04, 2010 6:47 pm

Re: Windows Mobile 6 WVGA Client [Updated 8/11/2010]

Postby spokanedj » Thu Aug 12, 2010 7:15 pm

flatliner wrote:- Yes I can see all channels. when I select one and press show the status line says i.e channel 3 loaded, but top and bottom box stay black/empty

I would check the channel settings in the Remote Potato configuration. Does it work from the web interface?

flatliner wrote:- Taking away the "/" did the trick ... although the streaming image window is quite small ... using the full size button in media player still gives a small streaming image window. can I change that setting somewhere?

I added Quality and Size settings in the latest update. Although I can't really get anything larger than 0.3 to work on my Tilt2 with performance problems.

flatliner wrote:- well if you have time left movies would be great ... as said I don't mind too help out with the design ... making it look as cool as the iphone app


I'm guessing movies wouldn't be any different than the Recorded TV. I'm open to someone with VS2008 and better UI skills than me to offer some assistance on the UI.
Smart Potato for Windows Phone 7: http://www.ntworld.com
spokanedj
Hot Potato
 
Posts: 80
Joined: Fri Apr 23, 2010 7:51 pm

Re: Windows Mobile 6 WVGA Client [Updated 8/12/2010]

Postby flatliner » Thu Aug 12, 2010 8:30 pm

- Great the new version did solve my problem :-)

- Looks good now although I error messages that there is an issue with wmplayer. Maybe it does not close the stream right

- oke I will reinstall vs2008 come up with some ideas
flatliner
New Potato
 
Posts: 6
Joined: Wed Aug 04, 2010 6:47 pm

Re: Windows Mobile 6 WVGA Client [Updated 8/12/2010]

Postby flatliner » Thu Aug 12, 2010 8:39 pm

I played around with the settings all seems to work fine except the medium quality ... it fails to load the stream.
After I switched off the error reporting it returns fine to smart potato

Another odd thing is that even after refresh channels I still see the guide from last night and yes it'looks like it doesn't take into account the time zone which seems to be 2 hours off. All channels are shown as well while I configured favorites ones in the remote potato server. If I use the browser version all looks fine.
Any ideas?

the key board shows up when click connect and disappears automatically when connected.

Do you think it's possible to have wide screen as well?
flatliner
New Potato
 
Posts: 6
Joined: Wed Aug 04, 2010 6:47 pm

Re: Windows Mobile 6 WVGA Client [Updated 8/12/2010]

Postby bobgentry » Tue Sep 07, 2010 12:03 pm

Great work,
Could we please have a QVGA version

Thats 240x320 res.
I really like the app but it's difficult to use. Every time I try to move the scroll bar to get to the bottom buttons the keyboard pops up hiding them
bobgentry
New Potato
 
Posts: 5
Joined: Thu Apr 29, 2010 6:51 pm

Re: Windows Mobile 6 WVGA Client [Updated 8/12/2010]

Postby azieba » Mon Sep 13, 2010 7:42 pm

I am having the same problem as some of you with my HTC Imagio (Win Mobile 6.5). I enter the information correctly, but cannot log in. I get the following client message - "An error message is available for this exception". On the server I get "Client connected" and "SendToBrowser: No. of bytes sent: 67". If I turn off security on the server it works great. If I turn it on, I get those messages. I can login fine via IE Mobile with my userid and password with security on. This app is great!!!!, but I can't leave security off. I am running Tech Preview 0.92.10 on the server side. The client was downloaded on 9/10/2010.

Any help would be appreciated.
azieba
Raw Potato
 
Posts: 3
Joined: Sat Mar 06, 2010 1:23 pm

Re: Windows Mobile 6 WVGA Client [Updated 8/12/2010]

Postby spokanedj » Mon Sep 13, 2010 8:49 pm

The security issue is a known problem and I've tried to resolve it without any success. He is using both HTTP Basic Authentication and a username/password to retrieve a token that must then be sent for all other requests. If you check use security, enter a username and password and then uncheck use security, it will still require a username/password but NOT use HTTP Basic Authentication. That is the best that I can come up with right now. The Client is sending Basic Authentication using the .NET framework for all requests. Something on the server just doesn't like it.
Smart Potato for Windows Phone 7: http://www.ntworld.com
spokanedj
Hot Potato
 
Posts: 80
Joined: Fri Apr 23, 2010 7:51 pm

Re: Windows Mobile 6 WVGA Client [Updated 8/12/2010]

Postby spokanedj » Mon Oct 18, 2010 10:26 pm

I updated the current version to include a workaround for the search problem. Search should now work and return results. I had some wierd issues with .93, but a restart of Remote Potato allowed the searching to work.
Smart Potato for Windows Phone 7: http://www.ntworld.com
spokanedj
Hot Potato
 
Posts: 80
Joined: Fri Apr 23, 2010 7:51 pm

PreviousNext

Return to Themes and Apps

Who is online

Users browsing this forum: No registered users and 1 guest

cron