So frustrating: juddery playback everywhere but WP7

Can't access your home PC, or stream from it over the Internet? Need to forward ports? Post your problems here, exchange tips and read the FAQ about how to get things working.
Forum rules
No spamming, flaming or excessive self-promotion.

So frustrating: juddery playback everywhere but WP7

Postby ianken » Wed Apr 04, 2012 5:27 am

Silverlive via desktop: (silverlight 5 installed) : jerky/juddery playback
Android (via RMC and a variety of external players): less jerky than in the browser on the dekstop.
Windows Phone 7 via Media Buddy: smooth as butter. Seriously, Media Buddy plays the way all the others SHOULD, but do not. But oddly, the fidelity is not as good.

This is really frustrating. I assume the server streams a bit differently to the various clients. My Windows Phone is not my primary device, and I'd love to use this on my Galaxy Tab 10.1 if I could get it to play smoothly.

Is there anything obvious, some setting I could tweak?

On the Android side of things I've tried:

Rock Player
VPlayer
Dice Player
And the various built-in players.
ianken
Hot Potato
 
Posts: 21
Joined: Thu Apr 15, 2010 4:12 am
Location: Redmond WA USA

Re: So frustrating: juddery playback everywhere but WP7

Postby PeeWee » Fri Apr 06, 2012 8:40 pm

Hi, I use Daroon Player on Android, it's the best for me, but your experience may be different. Give it a try...
PeeWee
Wise Potato
 
Posts: 229
Joined: Thu Apr 29, 2010 8:36 am

Re: So frustrating: juddery playback everywhere but WP7

Postby ianken » Sat Apr 07, 2012 4:48 am

Got a market link? It does not appear to be there.
ianken
Hot Potato
 
Posts: 21
Joined: Thu Apr 15, 2010 4:12 am
Location: Redmond WA USA

Re: So frustrating: juddery playback everywhere but WP7

Postby ianken » Sun Apr 08, 2012 12:50 am

Found it on the developers site. No better than Dice, which is almost there.

But Media Buddy on WP7 is like butter. Arg!
ianken
Hot Potato
 
Posts: 21
Joined: Thu Apr 15, 2010 4:12 am
Location: Redmond WA USA

Re: So frustrating: juddery playback everywhere but WP7

Postby andreaseide » Tue Apr 10, 2012 12:31 pm

Hi.
Have you tried th Remote Media Center app on your Galaxy Tab10?
Piet has a beta version with added possibility to set bitrate yourself.
--AndreasE--
Remote Potato Forum Moderator.

FAQ: How to post debug logs | How to clear your browser cache
User avatar
andreaseide
Wise Potato
 
Posts: 399
Joined: Wed Mar 03, 2010 7:25 pm
Location: Trondheim, Norway

Re: So frustrating: juddery playback everywhere but WP7

Postby ianken » Wed Apr 11, 2012 5:00 am

andreaseide wrote:Hi.
Have you tried th Remote Media Center app on your Galaxy Tab10?
Piet has a beta version with added possibility to set bitrate yourself.


Yep! I'm on the beta now and I've sent feedback to him. The new experimental bit rate settings yield better behavior in the in-box player vs the default settings. But playback of 29.97hz and 59.94hz content is still pretty glitchy in a periodic, rythmic manner. 23.976 hz stuff from my video collection is much better. I suspect an issue on the transcode side.

Edit... Just went and played some 25hz stuff in my collection. Its silky smooth. Now I really think there's a wonky issue on the server. And Carl wont see it if he tests with 25hz UK content. On 23.976 film it will be somewhat subtle.
ianken
Hot Potato
 
Posts: 21
Joined: Thu Apr 15, 2010 4:12 am
Location: Redmond WA USA

Re: So frustrating: juddery playback everywhere but WP7

Postby axioms » Wed Apr 11, 2012 9:19 pm

I have been asking about this for a while now. At least you recieved some replies. Only one person attempted help when I intially brought this up. I guess I was not asking the right questions :( . I also think the problem lies on the server/transcode side. My issues lie with all HD recordings using the wtv container. With RP, SD plays back fine, HD introduces all kind of judder, just like you described. My initial though was the transcode was having issues with any broadcast that used h264 inside the wtv container (recording). Maybe it is something else entirely, like a framerate issue. SD recordings play fine HD, not so much, very juddery, just like you described. I know its not a network issue on my side. Plenty of bandwidth and hardware is up to snuff. I dont use RP much anymore because of this. Although I check back every so often to see if a fix has been discovered. Still hearing crickets when I check back and look at my prior posts....

Good luck. I hope someone lends you more help then I recieved. Hopefully, you will find a solution.


viewtopic.php?f=17&t=1153
viewtopic.php?f=12&t=1316
axioms
New Potato
 
Posts: 6
Joined: Wed Jul 06, 2011 2:22 pm

Re: So frustrating: juddery playback everywhere but WP7

Postby ianken » Thu Apr 12, 2012 4:51 am

I'm 99% certain this is the transcoder forcing 25Hz on the encode. For folks in 25Hz content land, this is no big deal.

If I use this command line I get smooth playback, as smooth as can be expected given the nature of the content:

Code: Select all
ffmpeg -i "480i_29.97.wtv" -sn -vf "yadif=0:0:0,crop=in_w-2*8:in_h-2*8"  -vcodec libx264 -crf 20 -strict experimental -acodec aac -ac 2 -ab 128k -y "test.mkv"


However, if I add "-r 25" to force 25Hz? I get the exact sort of glitchy playback I see on the Andoird and Silverlight clients.

Code: Select all
"ffmpeg  -i "480i_29.97.wtv" -sn -vf "yadif=0:0:0,crop=in_w-2*8:in_h-2*8"  -r 25 -vcodec libx264 -crf 20 -strict experimental -acodec aac -ac 2 -ab 128k -y "test.mkv"


Yes, I know MKV is not streaming. But it allows me to play and reproduce what I am seeing perfectly.

Alas, using the custom FFMPEG option filed to set "-r 0" which should match input to output just breaks streaming.
ianken
Hot Potato
 
Posts: 21
Joined: Thu Apr 15, 2010 4:12 am
Location: Redmond WA USA

Re: So frustrating: juddery playback everywhere but WP7

Postby piet5211 » Thu Apr 12, 2012 4:10 pm

Although I am surprised this issue has not been brought up more often, I think it is a big deal given the large proportion of US users (almost 50% of RMC).
Maybe the dropbox link to some sample 24.xx en 29.xx Hz videos could be shared here for others to have a look at it...
It is great when you use Remote Media Center for android, see frequently asked questions, any donations would be appreciated.
piet5211
Top Potato
 
Posts: 156
Joined: Sun Jan 09, 2011 9:11 pm
Location: The Netherlands

Re: So frustrating: juddery playback everywhere but WP7

Postby ianken » Sun Apr 15, 2012 5:25 am

Alas, the stuff is copyrighted, even if small samples. I'll PM Carlos with links.

I posted a followup in the bugs section. I have verified that it is indeed the case that the server is forcing 25Hz at encode time.

viewtopic.php?f=9&t=1393
ianken
Hot Potato
 
Posts: 21
Joined: Thu Apr 15, 2010 4:12 am
Location: Redmond WA USA


Return to Support - Streaming / Network / Connectivity

Who is online

Users browsing this forum: Google [Bot] and 1 guest

cron